Hi,

I've just set up a new PC with RH Linux 7.3. Everything works great
except for one little thing: the PC speaker never makes a beep. In other
words, this little script never makes a sound:

#!/bin/bash
echo -en '\a'

Actually, it _does_ make a sound if I'm running KDE with System
Notification turned on, but in that case the sound is generated by my
PC's sound card. If I turn off System Notification, I get nothing
but silence. This is the case regardless of my 'xset b' settings.
In fact, my script ends immediately even if I set the duration of the beep
to be very, very long. On past RH 7.3 installations, I've discovered
that KDE's accessibility module 'kaccess' can be configured to turn off
the system bell, but I've not run 'kaccess' on this system, and there's
no trace of the telltale 'kaccessrc' under my KDE home directory.

If I run my script under a virtual console (i.e., without XFree86 or
KDE being involved), I get the same result: my script ends immediately,
and I hear no sound. Increasing the duration of the beep using 'setterm
-blength <duration>' makes no difference. If I take XFree86 and KDE out
of the picture by booting to runlevel 3, I get exactly the same behavior.

I can confirm that my PC speaker is correctly connected. My motherboard
BIOS has a nifty feature that gives me a voice message when the POST
is complete and the system has started booting, and I hear that over the
PC speaker. I've also heard a POST beep code when I'd installed a bad
memory module.

I know that to many folks, a beepless PC speaker is a good thing, and I
must say that I largely agree. However, certain apps such as GNU Emacs
issue their beeps in such a way that KDE's System Notification doesn't
handle them. It's those beeps that I'd like to hear. Were it not for
the sounds I hear from the BIOS, I'd almost think that the speaker wasn't
connected. I've doublechecked the speaker's connection to the motherboard
using the motherboard manual, and it looks correct. On the other hand,
the fact that my beep script exits immediately regardless of the beep
duration I've chosen makes me wonder if perhaps there's something weird
about my motherboard/CPU combination that's preventing the system bell
from working. Perhaps my system is just too fast! :-)

Here's the specs on my PC:

Antec Sontata case w/Antec TruePower 380W power supply
Supermicro P4SGA+ motherboard (Intel 845GE chipset)
Intel Pentium 4 2.66 GHz CPU
1 GB RAM in two 512 MB modules (PC233 SDRAM)
Two 40 GB Maxtor 7200 RPM ATAPI UDMA hard drives
Sony DVD-ROM and CD-RW drives
nVidia Geforce4 AGP graphics card
RedHat Linux 7.3 -- vanilla code other than a freshly compiled
2.4.20 kernel
KDE 3.0.0.something
XFree86 4.2.something

At this time I'm running RH 7.3 on several other PCs, none faster than a
Pentium III-700, and the system beep works on all of them.

Any ideas of what might be causing my problem?

Thanks,
Dave
--
Dave Ulrick
Email: [email]d-ulrickniu.edu[/email]
Web: [url]http://www.niu.edu/~ulrick/[/url]