Professional Web Applications Themes

Why Cfform with flash not working - Coldfusion - Advanced Techniques

Okay so im trying to build a new navigation system based of a flash form. I want tabs on the top to hold different kinds of links and then when the user clicks one of the buttons under that tab it brings them to that page. Right now it doesn't work at all, no flash loads, and i recieve no errors. I have flash 8 installed and have tried viewing my linkbar in both firefox and IE with no luck. Its probably something simple, ive never worked with flash forms before so im kinda a novice. Any help is appreciated ...

  1. #1

    Default Why Cfform with flash not working

    Okay so im trying to build a new navigation system based of a flash form. I
    want tabs on the top to hold different kinds of links and then when the user
    clicks one of the buttons under that tab it brings them to that page. Right now
    it doesn't work at all, no flash loads, and i recieve no errors. I have flash 8
    installed and have tried viewing my linkbar in both firefox and IE with no
    luck. Its probably something simple, ive never worked with flash forms before
    so im kinda a novice. Any help is appreciated thanks. Some of the tabs are
    empy because i haven't made buttons for them yet. So yeah, i didn't like cut
    any code out or anything, just havn't coded that part yet.

    <cfform name="myform" height="50" width="800" format="Flash" skin="HaloBlue">
    <cfformgroup type="tabnavigator" height="50" style="marginTop: 0">

    <cfformgroup type="page" label="Site Links">
    <cfinput type="button" name="Home"
    onClick="MM_goToURL('parent','index.cfm');return doent.MM_returnValue">
    <cfinput type="button" name="Site Projects"
    onClick="MM_goToURL('parent','projects.cfm');retur n doent.MM_returnValue">
    <cfinput type="button" name="News Archive"
    onClick="MM_goToURL('parent','news_archive.cfm');r eturn
    doent.MM_returnValue">
    <cfinput type="button" name="Whats New"
    onClick="MM_goToURL('parent','default.cfm');return doent.MM_returnValue">
    <cfinput type="button" name="Readme/Help"
    onClick="MM_goToURL('parent','About.cfm');return doent.MM_returnValue">


    </cfformgroup>

    <cfformgroup type="page" label="Communication">
    <cfinput type="button" name="Chat" onClick="MM_goToURL('parent','chat
    room.cfm');return doent.MM_returnValue">
    <cfinput type="button" name="Public Rant" onClick="Public Rant.cfm">
    <cfinput type="button" name="Rant Box" onClick="public box.cfm">
    <cfinput type="button" name="Home" onClick="index.cfm">

    </cfformgroup>

    <cfformgroup type="page" label="Downloads">


    </cfformgroup>

    <cfformgroup type="page" label="Services">


    </cfformgroup>

    <cfif session.userrole NEQ "Guest">
    <cfformgroup type="page" label="Members Links">

    </cfformgroup>
    </cfif>
    <cfif session.userrole EQ "Admin">
    <cfformgroup type="page" label="Admin Links">

    </cfformgroup>
    </cfif>

    </cfformgroup>
    </cfform>

    kenji776 Guest

  2. #2

    Default Re: Why Cfform with flash not working

    kenji776 ,

    Start by testing a very simple form - containing one element only. See if it
    loads correctly.

    Also check to make sure the cfform.js file is accessible. It should be
    located at /CFIDE/scripts/cfform.js, where "/" is your web root. It can cause
    problems if it is not accessible from that location.
    http://www.macromedia.com/cfusion/knowledgebase/index.cfm?id=tn_18653

    mxstu Guest

  3. #3

    Default Re: Why Cfform with flash not working

    I do have some basic forms working, I built a flash form for people to create
    accounts. I don't know what this ones problem is. I have made forms with
    similar properties work, aka forms with tabs and inputs and such. This one is
    just being strange. Thanks for the advice though, i may try to simplify it a
    bit.

    kenji776 Guest

  4. #4

    Default Re: Why Cfform with flash not working

    So you can successfully run other flash forms, but not this one? Try turning on
    the flash debugging setting in the CF Administrator to see if any errors are
    thrown. (I can't rememeber the setting name and I don't have access to CF at
    the moment.).

    mxstu Guest

  5. #5

    Default Re: Why Cfform with flash not working

    I just noticed you have a lot of spaces in your form field names. I don't think that is allowed. Try removing the spaces and see what happens.


    mxstu Guest

  6. #6

    Default Re: Why Cfform with flash not working

    I am exploring cfform with flash format myself.
    Tested lines of your code:
    <cfformgroup type="tabnavigator" >
    <cfformgroup type="page" label="Site Links">
    <cfinput type="button" value="Home" name="Home"
    onChange="MM_goToURL
    ('parent','index.cfm');return doent.MM_returnValue">
    </cfformgroup>
    <cfformgroup type="page" label="Communic">
    <cfinput type="button" value="Chat" name="Chat"
    onChange="MM_goToURL
    ('parent','index.cfm');return doent.MM_returnValue">
    </cfformgroup>
    </cfformgroup>
    it does not flash but if replace onClick with onChange it does.
    Check
    http://livedocs.macromedia.com/coldfusion/7/htmldocs/wwhelp/wwhimpl/common/html/
    wwhelp.htm?context=ColdFusion_Doentation&file=p art_cfm.htm
    OnClick event is not listed there. Maybe it's not supported by ColdFusion?


    CF_Oracle Guest

  7. #7

    Default Re: Why Cfform with flash not working

    Hmm still doesn't work. I took out all the spaces and changed from onclick to onchange. Still it doesn't work. Any ideas?
    kenji776 Guest

  8. #8

    Default Re: Why Cfform with flash not working

    I tested all your code. For some reason (reserved word?) flash 'does not like' the line <cfinput type="button" value="View Weblogs" name="ViewWeblogs">.
    When replaced name with "Weblogs" run fine!
    CF_Oracle Guest

  9. #9

    Default Re: Why Cfform with flash not working

    Okay I got it working. Turns out I had two fields called viewweblogs, so that
    made an error. Also it didn't like the MMonclick code. So now I just have a few
    questions.
    1)How to I make all the buttons on one row, instead of breaking the line after
    each button?
    2)How do I make the background color of the form black, behind the buttons is
    still all white and it looks awful.
    3)Whats a simple and effective way to make those buttons links to pages, since
    I can't seem to use onclick?

    Thanks for the help. If you need ill post the code, its basically the same,
    just remove one of the buttons called viewweblogs. Its in both media, and
    communications.

    kenji776 Guest

Similar Threads

  1. cfform type="flash" not working in safari
    By SilentBob'secretfusion in forum Coldfusion Flash Integration
    Replies: 0
    Last Post: February 20th, 06:52 PM
  2. CFForm stops working
    By Diacritical in forum Coldfusion Flash Integration
    Replies: 0
    Last Post: August 4th, 08:14 PM
  3. cfform type="flash" not working on IIS 6.0? Tried workaround
    By SilentBob'secretfusion in forum Coldfusion Flash Integration
    Replies: 1
    Last Post: February 1st, 06:19 PM
  4. cfform not working with onSubmit
    By shahzad in forum Macromedia ColdFusion
    Replies: 5
    Last Post: August 26th, 08:19 PM
  5. CFFORM validate not working
    By Rick in forum Coldfusion - Advanced Techniques
    Replies: 3
    Last Post: August 15th, 08:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139