-- Murray --- ICQ 71997575 Adobe Community Expert (If you *MUST* email me, don't LAUGH when you do so!) ================== http://www.projectseven.com/go - DW FAQs, Tutorials & Resources http://www.dwfaq.com - DW FAQs, Tutorials & Resources ================== "Jansolo" wrote in message news:fr3bvo$263$macromedia.com...[ref] > Been away - sorry! > > With regards to conditional comments - you can't put them in a CSS file > can > you? From what I am reading when doing a Google search you can if the CSS > is in > the HTML page itself but not in a CSS file! >[/ref] [allowsmilie] => 1 [showsignature] => 0 [ipaddress] => [iconid] => 0 [visible] => 1 [attach] => 0 [infraction] => 0 [reportthreadid] => 0 [isusenetpost] => 1 [msgid] => [ref] => [htmlstate] => on_nl2br [postusername] => Murray [ip] => forums@HAHAgrea [isdeleted] => 0 [usergroupid] => [membergroupids] => [displaygroupid] => [password] => [passworddate] => [email] => [styleid] => [parentemail] => [homepage] => [icq] => [aim] => [yahoo] => [msn] => [skype] => [showvbcode] => [showbirthday] => [usertitle] => [customtitle] => [joindate] => [daysprune] => [lastvisit] => [lastactivity] => [lastpost] => [lastpostid] => [posts] => [reputation] => [reputationlevelid] => [timezoneoffset] => [pmpopup] => [avatarid] => [avatarrevision] => [profilepicrevision] => [sigpicrevision] => [options] => [akvbghsfs_optionsfield] => [birthday] => [birthday_search] => [maxposts] => [startofweek] => [referrerid] => [languageid] => [emailstamp] => [threadedmode] => [autosubscribe] => [pmtotal] => [pmunread] => [salt] => [ipoints] => [infractions] => [warnings] => [infractiongroupids] => [infractiongroupid] => [adminoptions] => [profilevisits] => [friendcount] => [friendreqcount] => [vmunreadcount] => [vmmoderatedcount] => [socgroupinvitecount] => [socgroupreqcount] => [pcunreadcount] => [pcmoderatedcount] => [gmmoderatedcount] => [assetposthash] => [fbuserid] => [fbjoindate] => [fbname] => [logintype] => [fbaccesstoken] => [newrepcount] => [vbseo_likes_in] => [vbseo_likes_out] => [vbseo_likes_unread] => [temp] => [field1] => [field2] => [field3] => [field4] => [field5] => [subfolders] => [pmfolders] => [buddylist] => [ignorelist] => [signature] => [searchprefs] => [rank] => [icontitle] => [iconpath] => [avatarpath] => [hascustomavatar] => 0 [avatardateline] => [avwidth] => [avheight] => [edit_userid] => [edit_username] => [edit_dateline] => [edit_reason] => [hashistory] => [pagetext_html] => [hasimages] => [signatureparsed] => [sighasimages] => [sigpic] => [sigpicdateline] => [sigpicwidth] => [sigpicheight] => [postcount] => 10 [islastshown] => 1 [isfirstshown] => [attachments] => [allattachments] => ) --> WHY WON"T THIS EVER WORK FOR ME???? - Macromedia Dynamic HTML

WHY WON"T THIS EVER WORK FOR ME???? - Macromedia Dynamic HTML

I try all the time to construct websites using CSS and they look great on a Mac using Safari/Firefox but whenever I test them on a stupid Windows IE they never work properly - EVER!!! I have been playing with one which can be seen here: Site: http://www.names4design.co.uk/ultraclean CSS: http://www.names4design.co.uk/ultraclean/default.css As said on a mac - great, it is all where it should be, but on a Wiindows - the nav section is under the content and the content is not floating right enough. Anyone have any ideas where I am going so wrong or am I destined to use ...

  1. #1

    Default WHY WON"T THIS EVER WORK FOR ME????

    I try all the time to construct websites using CSS and they look great on a Mac
    using Safari/Firefox but whenever I test them on a stupid Windows IE they never
    work properly - EVER!!!

    I have been playing with one which can be seen here:

    Site:
    http://www.names4design.co.uk/ultraclean

    CSS:
    http://www.names4design.co.uk/ultraclean/default.css

    As said on a mac - great, it is all where it should be, but on a Wiindows -
    the nav section is under the content and the content is not floating right
    enough.

    Anyone have any ideas where I am going so wrong or am I destined to use tables
    forever??

    Cheers

    Jan

    Jansolo Guest

  2. #2

    Default Re: WHY WON"T THIS EVER WORK FOR ME????



    This looks fine in IE7 on a win machine; sounds like you may be using
    that very old IE verion for the Mac. You have to beware that not all
    browsers remder things the same. If you look at the sample templates
    that come in cs3 you will see where they have made adjustments for
    different browsers.
     
    Philo Guest

  3. #3

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    It breaks in IE6/PC.

    First thing I'd do is to remove the positioning from all interior divs.
    Then I'd use an IE6 conditional comment to set the width of the nav
    container.

    --
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
    ==================


    "Philo" <net> wrote in message
    news:fqjmm3$qfa$macromedia.com... [/ref]

    Murray Guest

  4. #4

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    "Then I'd use an IE6 conditional comment to set the width of the nav container."

    Could you elaborate on that? I don't really use conditional comments apart
    from those I copy and paste - where can I get a list of these as well as I come
    across them more and more.

    Thanks for both comments though.

    Jansolo Guest

  5. #5

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    Google "IE CONDITIONAL COMMENTS" - you'll see....

    --
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
    ==================


    "Jansolo" <com> wrote in message
    news:fqjvqq$6th$macromedia.com... 

    Murray Guest

  6. #6

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    Cheers chap - I have tried all sorts of google searches but never got the term correct.
    Jansolo Guest

  7. #7

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    The browser I am testing it on on the PC is IE 6.

    From doing the Google search, I see that you can't include these conditional
    comments within a CSS - it would have to be on the page itself.

    Also, I have the #nav width set already (190px) so just can't see how to go
    about it - I am being thick, I am well aware of that!!!

    Jansolo Guest

  8. #8

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    > From doing the Google search, I see that you can't include these 

    Yes. Why is that a problem?
     

    Clearly, IE6 is not following that directive, since you can see that it's
    much wider in that browser.

    I am not sure why it's not properly sized, to be honest....

    --
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
    ==================


    "Jansolo" <com> wrote in message
    news:fqlop4$7c5$macromedia.com... 

    Murray Guest

  9. #9

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    Been away - sorry!

    With regards to conditional comments - you can't put them in a CSS file can
    you? From what I am reading when doing a Google search you can if the CSS is in
    the HTML page itself but not in a CSS file!

    Jansolo Guest

  10. #10

    Default Re: WHY WON"T THIS EVER WORK FOR ME????

    You cannot put them in a CSS file. But you can use them to write a LINK to
    a CSS file -

    <!--[if IE]>
    <link href="foo.css" rel="stylesheet" type="text.css">
    <[endif]-->

    --
    Murray --- ICQ 71997575
    Adobe Community Expert
    (If you *MUST* email me, don't LAUGH when you do so!)
    ==================
    http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
    http://www.dwfaq.com - DW FAQs, Tutorials & Resources
    ==================


    "Jansolo" <com> wrote in message
    news:fr3bvo$263$macromedia.com... 

    Murray Guest

Similar Threads

  1. #39588 [NEW]: unpack("a*", "abc\0") does not work as expected
    By pprasse at actindo dot de in forum PHP Bugs
    Replies: 1
    Last Post: November 22nd, 02:23 PM
  2. Replace(myVar,":",":<br>","all") does not work
    By xSist in forum Coldfusion - Getting Started
    Replies: 3
    Last Post: May 24th, 06:46 PM
  3. FScommand("Exec","myapplication.exe") doesnot work on Trial version MX?
    By yn webforumsuser@macromedia.com in forum Macromedia Flash Actionscript
    Replies: 1
    Last Post: January 13th, 08:45 AM
  4. "Select" & "Order By" OK- ''WHERE'' Does'nt Work !
    By ian justice in forum PHP Development
    Replies: 23
    Last Post: November 20th, 06:10 AM
  5. How to make the "search text" feature work with non "txt" file
    By Sharon F in forum Windows XP/2000/ME
    Replies: 0
    Last Post: June 30th, 07:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •