Professional Web Applications Themes

WinTV 401 with RH8.0 and xawtv - Linux Setup, Configuration & Administration

Jon Hills wrote: > Hi, > > I cant seem to get video out of my new TV card with xawtv. All I get > is a bunch of coloured dots being crammed in at the top of the xawtv > window. It sort of looks like coloured static. I've noticed that I get > an error about i2c not being found when I try 'insmod i2c'. However, > there are i2c-ish modules loaded in memory. when I start-up xawtv, I > set it to use the following > > TV-norm: NTSC > Video Source: Television > Audio Mode: auto ...

  1. #1

    Default Re: WinTV 401 with RH8.0 and xawtv

    Jon Hills wrote:
    > Hi,
    >
    > I cant seem to get video out of my new TV card with xawtv. All I get
    > is a bunch of coloured dots being crammed in at the top of the xawtv
    > window. It sort of looks like coloured static. I've noticed that I get
    > an error about i2c not being found when I try 'insmod i2c'. However,
    > there are i2c-ish modules loaded in memory. when I start-up xawtv, I
    > set it to use the following
    >
    > TV-norm: NTSC
    > Video Source: Television
    > Audio Mode: auto
    > Freq. Table: us-cable
    > Capture: overlay
    >
    > (ps. I'm in canada, and the cable is hooked up to the TV coaxial
    > connector)
    >
    > I am wondering about all the nice PLL switching off messages I get in
    > dmesg. Doesn't a TV need its PLL to be active to properly sync to a
    > television signal? I'm guessing here...
    >
    > Any ideas?
    > Jon
    I guess the tuner type is not set correctly.

    Check

    [url]http://fftv.sourceforge.net/Setup_X11_keyboard_v4l_tv-out.html[/url]


    You may like fftv [url]http://fftv.sourceforge.net[/url]

    Vampire at Wicked Empire Guest

  2. #2

    Default Re: WinTV 401 with RH8.0 and xawtv

    The 401's you buy in canada auto probe/insert just fine with respect to
    NORM,
    I have 5 of them and have them working fine in RH7.2 7.3 8.0 9.0 and now
    linux 2.6-test1 kernel which ROCKS!!!

    you will probably find when you set to Composite/Svideo and plug in a
    video source to the 401 you get that video, but not the tuner video,
    it is, as you discribed, jumble of colours dots and (i got a lot of
    green).
    This is a result of the tuner not working properly, but as you noted,
    you have the NORM set ok, and us-cable is what i set (and i am in
    Toronto).
    So you must have the same problem I had with the 401 card when i just
    installed
    my new 2.6 kernel,
    the problem was the dependancy module list for bttv didnt include
    videodev
    and the kicker, bttv module didnt kick in "tuner"
    which is the magic peice.
    I see by your lsmod you dont have tuner in there,
    modprobe turner - and your laughing!!!!

    oh actaully now i see you have tuner in your lsmod ( i will leave that
    info in my posting , as it might be helpfull to others).....
    try using mplayer i always thought xawtv ed large ...
    when i did use it, it always needed channels defined in its .xawtv file
    in order to work,
    regardless, check you composite/s-video just to make sure it works,
    if it does, then it is definitely your NORM and channel freq. assignment,
    i got the same errors when i used xawtv, and solved it right away by
    simply putting the channel list in the .xawtv file, off the top of my
    head somthing like

    [3]
    channel 3

    or

    [chan 3]
    3

    or something simple like that, see man page

    -Resu Xunil



    On Tue, 15 Jul 2003 23:09:55 -0400, Jon Hills wrote:
    > Hi,
    >
    > I cant seem to get video out of my new TV card with xawtv. All I get is
    > a bunch of coloured dots being crammed in at the top of the xawtv
    > window. It sort of looks like coloured static. I've noticed that I get
    > an error about i2c not being found when I try 'insmod i2c'. However,
    > there are i2c-ish modules loaded in memory. when I start-up xawtv, I set
    > it to use the following
    >
    > TV-norm: NTSC
    > Video Source: Television
    > Audio Mode: auto
    > Freq. Table: us-cable
    > Capture: overlay
    >
    > (ps. I'm in canada, and the cable is hooked up to the TV coaxial
    > connector)
    >
    > I am wondering about all the nice PLL switching off messages I get in
    > dmesg. Doesn't a TV need its PLL to be active to properly sync to a
    > television signal? I'm guessing here...
    >
    > Any ideas?
    > Jon
    >
    > -------------------------------
    > some useful stuff below to help
    >
    > -------------------
    > lsmod shows this...
    > -------------------
    >
    > Module Size Used by Tainted: P lirc_i2c
    > 4096 0 (autoclean) lirc_dev 8896 1 (autoclean)
    > [lirc_i2c] ide-cd 30632 0 (autoclean) cdrom
    > 30208 0 (autoclean) [ide-cd] nvaudio 25480 0
    > (autoclean) ac97_codec 12072 0 (autoclean) [nvaudio]
    > soundcore 5956 2 (autoclean) [nvaudio] tuner
    > 10400 1 (autoclean) tvaudio 13628 0
    > (autoclean) (unused) msp3400 16524 1 (autoclean) bttv
    > 67904 1
    > videodev 7584 3 [bttv] i2c-algo-bit 7912 1
    > [bttv] i2c-core 17828 0 [lirc_i2c tuner tvaudio msp3400
    > bttv i2c-algo-bit]
    > autofs 11940 0 (autoclean) (unused) nvnet
    > 30464 2
    > iptable_filter 2284 0 (autoclean) (unused) ip_tables
    > 13592 1 [iptable_filter] serial 55972 0
    > (autoclean) mousedev 5076 1 keybdev
    > 2688 0 (unused) hid 20132
    > 0 (unused) input 5504 0 [mousedev keybdev hid]
    > ehci-hcd 15464 0 (unused) usb-ohci 19496
    > 0 (unused) usbcore 69664 1 [hid ehci-hcd usb-ohci]
    > ext3 61440 2
    > jbd 46932 2 [ext3] FastTrak 108004 2
    > sd_mod 12976 4
    > scsi_mod 99880 2 [FastTrak sd_mod]
    >
    > -----------------------------------
    > the tail end of dmesg shows this...
    > -----------------------------------
    >
    > ip_tables: (C) 2000-2002 Netfilter core team PCI: Setting latency timer
    > of device 00:04.0 to 64 divert: allocating divert_blk for eth0
    > i2c-core.o: i2c core module
    > i2c-algo-bit.o: i2c bit algorithm module Linux video capture interface:
    > v1.00
    > bttv: driver version 0.7.91 loaded
    > bttv: using 2 buffers with 2080k (4160k total) for capture bttv: Host
    > bridge is PCI device 10de:01e0 (nVidia Corporation) bttv: Bt8xx card
    > found (0).
    > bttv0: Bt878 (rev 17) at 01:07.0, irq: 11, latency: 32, memory:
    > 0xd8000000
    > bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is
    > 0070:13eb
    > bttv0: using: BT878(Hauppauge (bt878)) [card=10,autodetected] bttv0:
    > Hauppauge/Voodoo msp34xx: reset line init [5] i2c-core.o: adapter bt848
    > #0 registered as adapter 0. bttv0: Hauppauge eeprom: model=44371,
    > tuner=Philips FM1236 (2), radio=yes
    > bttv0: i2c: checking for MSP34xx 0x80... found i2c-core.o: driver i2c
    > msp3400 driver registered. msp34xx: init: chip=MSP3435G-B6, has NICAM
    > support msp3410: daemon started
    > bttv0: i2c attach [client=MSP3435G-B6,ok] i2c-core.o: client
    > [MSP3435G-B6] registered to adapter [bt848 #0](pos. 0). bttv0: i2c:
    > checking for TDA9875 0xb0... not found bttv0: i2c: checking for
    > TDA7432 0x8a... not found tvaudio: TV audio decoder + audio/video mux
    > driver tvaudio: known chips:
    > tda9840,tda9873h,tda9874h/a,tda9850,tda9855,tea6300,tea6420,tda8425,pic16c54
    > (PV951)
    > i2c-core.o: driver generic i2c audio driver registered. i2c-core.o:
    > driver i2c TV tuner driver registered. tuner: probing bt848 #0 i2c
    > adapter [id=0x10005] tuner: chip found 0xc2 bttv0: i2c attach
    > [client=Philips NTSC,ok] i2c-core.o: client [Philips NTSC] registered to
    > adapter [bt848 #0](pos. 1). bttv0: registered device video0
    > bttv0: registered device vbi0
    > bttv0: registered device radio0
    > Intel 810 + AC97 Audio, version 0.22, 00:45:09 Jul 9 2003 PCI: Setting
    > latency timer of device 00:06.0 to 64 i810: NVIDIA nForce Audio found at
    > IO 0xe800 and 0xe400, IRQ 5 i810_audio: Audio Controller supports 6
    > channels. i810_audio: Defaulting to base 2 channel mode. ac97_codec:
    > AC97 Audio codec, id: 0x414c:0x4720 (ALC650) i810_audio: AC'97 codec 0,
    > new EID value = 0x05c7 i810_audio: AC'97 codec 0, DAC map configured,
    > total channels = 6 ide-floppy driver 0.99.newide hdc: ATAPI 48X DVD-ROM
    > drive, 256kB Cache Uniform CD-ROM driver Revision: 3.12
    > cdrom: This disc doesn't have any tracks I recognize! bttv0: PLL:
    > 28636363 => 35468950 ... ok tuner: TV freq (0.-6) out of range (44-958)
    > lirc_dev: IR Remote Control driver registered, at major 61 i2c-core.o:
    > driver i2c ir driver registered. lirc_i2c: chip found 0x18 (Hauppauge
    > IR) bttv0: i2c attach [client=Hauppauge IR,ok] i2c-core.o: client
    > [Hauppauge IR] registered to adapter [bt848 #0](pos. 2). tuner: TV freq
    > (0.-6) out of range (44-958) bttv0: PLL: switching off tuner: TV freq
    > (0.-6) out of range (44-958) tuner: TV freq (0.-6) out of range (44-958)
    > bttv0: PLL: 28636363 => 35468950 ... ok tuner: TV freq (0.-6) out of
    > range (44-958) tuner: TV freq (0.-6) out of range (44-958) bttv0: PLL:
    > switching off
    > tuner: TV freq (0.-6) out of range (44-958) tuner: TV freq (0.-6) out of
    > range (44-958) bttv0: PLL: 28636363 => 35468950 ... ok tuner: TV freq
    > (0.-6) out of range (44-958) bttv0: PLL: switching off tuner: TV freq
    > (0.-6) out of range (44-958) bttv0: PLL: 28636363 => 35468950 ... ok
    > tuner: TV freq (0.-6) out of range (44-958) bttv0: PLL: switching off
    > tuner: TV freq (0.-6) out of range (44-958) bttv0: PLL: 28636363 =>
    > 35468950 ... ok tuner: TV freq (0.-6) out of range (44-958) tuner: TV
    > freq (0.-6) out of range (44-958) bttv0: PLL: switching off
    no-spam Guest

Similar Threads

  1. Can t get xawtv to work
    By TheDD in forum Linux Setup, Configuration & Administration
    Replies: 0
    Last Post: September 2nd, 08:12 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139