Professional Web Applications Themes

Wireless PCMIA problems - FreeBSD

I've tryed to use the Windows driver, but it doesn't seem to work. I did the following: # cd /usr/src/sys/modules/ndis/ # make && make install # cd ../if_ndis/ # cp /cdrom/driver/* ./ # ndiscvt -i ./netwpx96.inf -s ./wlpx96e.sys -o ndis_driver_data.h # make && make install # kldload ndis # kldload if_ndis When running dmesg there are no ndis0 to be found in the list. The only data linked to the card is the following: pccard0: <unknown card> (manufacturer=0x0101, product=0x0696) at function 0 pccard0: CIS info: 3Com, 3CRSHPW_96 Wireless LAN PC Card, (null) Regards Lars On Tuesday 15 February 2005 18:04, ...

  1. #1

    Default Re: Wireless PCMIA problems

    I've tryed to use the Windows driver, but it doesn't seem to
    work. I did the following:

    # cd /usr/src/sys/modules/ndis/
    # make && make install
    # cd ../if_ndis/
    # cp /cdrom/driver/* ./
    # ndiscvt -i ./netwpx96.inf -s ./wlpx96e.sys -o ndis_driver_data.h
    # make && make install
    # kldload ndis
    # kldload if_ndis

    When running dmesg there are no ndis0 to be found in the list.
    The only data linked to the card is the following:
    pccard0: <unknown card> (manufacturer=0x0101, product=0x0696) at function 0
    pccard0: CIS info: 3Com, 3CRSHPW_96 Wireless LAN PC Card, (null)

    Regards
    Lars

    On Tuesday 15 February 2005 18:04, you wrote:
    > On Tuesday 15 February 2005 10:40 am, Lars Hederidder wrote:
    > > Hey,
    > >
    > > I have a 3Com 3CRSHPW_96 Wireless PCMIA card for my laptop.
    > > However I'm a newbie at using PCMIA cards on FreeBSD.
    > >
    > > BSD finds the card when I plug it in, but it doesn't show up when
    > > I use the ifconfig command.
    > >
    > > Can anyone help me with this problem, so I can get it up and running.
    > > The system is a fresh installed FreeBSD 5.3
    > >
    > > Thanks in advance
    > > Lars
    >
    > When you say FreeBSD "sees" the card, do you mean it is associated with
    > a device, or just that the card's name appears in dmesg?
    >
    > It would appear, from the email message link below, that this card
    > requires the use of it's Windows drivers.
    >
    > [url]http://lists.freebsd.org/pipermail/freebsd-mobile/2004-September/004804.htm[/url]
    >l
    >
    > Follow the link below to the online handbook's chapter on wireless
    > networking. Read the whole chapter; but pay particular attention to
    > section 25.3.3.6.3, toward the bottom, regarding the NDISulator.
    >
    > [url]http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-wireless[/url].
    >html
    >
    > Best of luck,
    >
    > Andrew Gould
    Lars Hederidder Guest

  2. #2

    Default Re: Wireless PCMIA problems

    On Tuesday 15 February 2005 01:06 pm, Lars Hederidder wrote:
    > I've tryed to use the Windows driver, but it doesn't seem to
    > work. I did the following:
    >
    > # cd /usr/src/sys/modules/ndis/
    > # make && make install
    > # cd ../if_ndis/
    > # cp /cdrom/driver/* ./
    > # ndiscvt -i ./netwpx96.inf -s ./wlpx96e.sys -o ndis_driver_data.h
    > # make && make install
    > # kldload ndis
    > # kldload if_ndis
    >
    > When running dmesg there are no ndis0 to be found in the list.
    > The only data linked to the card is the following:
    > pccard0: <unknown card> (manufacturer=0x0101, product=0x0696) at
    > function 0 pccard0: CIS info: 3Com, 3CRSHPW_96 Wireless LAN PC
    > Card, (null)
    >
    > Regards
    > Lars
    >
    I've never messed with the NDISulator stuff; so I can't help you much at
    this point. All of my wireless cards use either the wi or ath drivers.

    Good luck,

    Andrew Gould
    Andrew L. Gould Guest

Similar Threads

  1. wireless lan problems
    By maxl in forum Windows Networking
    Replies: 5
    Last Post: July 17th, 03:37 PM
  2. Wireless Router TCP/IP problems
    By Sean in forum Windows Networking
    Replies: 0
    Last Post: July 15th, 05:59 AM
  3. Problems with Wireless connection setup
    By Rob Manger in forum Windows Networking
    Replies: 0
    Last Post: July 9th, 10:03 AM
  4. Problems with the wireless network
    By Mark Pulham in forum Windows Networking
    Replies: 0
    Last Post: July 3rd, 07:50 AM
  5. Wireless problems - Windows XP SP1 (Home Ed.)
    By Bill James in forum Windows Networking
    Replies: 0
    Last Post: June 29th, 03:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139