Professional Web Applications Themes

Wireless setup questions - Debian

I just installed a Orinoco 802.11b card in a Toshiba laptop running sid and it's working well, but I have some issues: 1. I'm now getting a "choose networking interface" option at bootup. How can I disable this? 2. eth0 is non-existant when dhcp attempts to connect for an IP, hence it fails, as do my network mounts,etc. After boot I have to issue a sudo pump -i eth0 to grab an address, then mount my shares. I tried moving pcmcia to earlier in the boot process by adjusting it's SXpcmcia symlink in rc2.d - that didn't make a difference. ...

  1. #1

    Default Wireless setup questions

    I just installed a Orinoco 802.11b card in a Toshiba laptop running sid and
    it's working well, but I have some issues:

    1. I'm now getting a "choose networking interface" option at bootup. How can I
    disable this?

    2. eth0 is non-existant when dhcp attempts to connect for an IP, hence it
    fails, as do my network mounts,etc. After boot I have to issue a sudo pump -i
    eth0 to grab an address, then mount my shares.

    I tried moving pcmcia to earlier in the boot process by adjusting it's
    SXpcmcia symlink in rc2.d - that didn't make a difference. I also added a
    pump -i eth0 command to bootmisc.sh w/o success. I didn't see anything in the
    wireless howto that helped.

    Thanks for any help resolving these problems...

    Jeff Elkins


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Jeff Elkins Guest

  2. #2

    Default Re: Wireless setup questions

    Jeff Elkins <jeffelkinsearthlink.net> writes:
    > 1. I'm now getting a "choose networking interface" option at
    > bootup. How can I disable this?
    You must have installed a package that provides this; you might look
    through the list of installed packages in something like aptitude.
    Looking through the links in /etc/rcS.d and /etc/rc2.d might also give
    you a hint of which package it is.
    > 2. eth0 is non-existant when dhcp attempts to connect for an IP,
    > hence it fails, as do my network mounts,etc. After boot I have to
    > issue a sudo pump -i eth0 to grab an address, then mount my shares.
    Do you have 'auto eth0' in your /etc/network/interfaces file? If so,
    take it out; then the network scripts won't try to bring up eth0 at
    boot time (before PCMCIA), but when pcmcia-cs discovers that you have
    a network card, it will run 'ifup eth0' on its own. (My impression is
    also that 'pump' is considered among the more, well, ghetto of the
    available DHCP clients, so you might try using 'dhcp-client' instead
    if you have weird DHCP problems.)

    So, your /etc/network/interfaces file should look (very loosely) like

    auto lo
    iface lo inet loopback
    iface eth0 inet dhcp

    --
    David Maze [email]dmazedebian.org[/email] [url]http://people.debian.org/~dmaze/[/url]
    "Theoretical politics is interesting. Politicking should be illegal."
    -- Abra Mitchell


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    David Z Maze Guest

  3. #3

    Default Re: Wireless setup questions

    On Monday 07 July 2003 11:02 am, David Z Maze wrote:
    >Jeff Elkins <jeffelkinsearthlink.net> writes:
    >> 1. I'm now getting a "choose networking interface" option at
    >> bootup. How can I disable this?
    >
    >You must have installed a package that provides this; you might look
    >through the list of installed packages in something like aptitude.
    >Looking through the links in /etc/rcS.d and /etc/rc2.d might also give
    >you a hint of which package it is.
    >
    >> 2. eth0 is non-existant when dhcp attempts to connect for an IP,
    >> hence it fails, as do my network mounts,etc. After boot I have to
    >> issue a sudo pump -i eth0 to grab an address, then mount my shares.
    >
    >Do you have 'auto eth0' in your /etc/network/interfaces file? If so,
    >take it out; then the network scripts won't try to bring up eth0 at
    >boot time (before PCMCIA), but when pcmcia-cs discovers that you have
    >a network card, it will run 'ifup eth0' on its own. (My impression is
    >also that 'pump' is considered among the more, well, ghetto of the
    >available DHCP clients, so you might try using 'dhcp-client' instead
    >if you have weird DHCP problems.)
    >
    >So, your /etc/network/interfaces file should look (very loosely) like
    >
    > auto lo
    > iface lo inet loopback
    > iface eth0 inet dhcp
    >
    >--
    Thanks,

    Only partial joy thus far. I added a DHCP="Y" to /etc/pcmcia/network.opts and
    that brings up the card with it's proper IP at boot, but still w/o shares
    mounted. Doing a sudo mount -a after boot fixes this, but of course I want to
    avoid that. The eventual user of this box never touches root.

    I eliminated the auto eth0 from interfaces and rebooted, but I still get the
    'Choose current network environment' screen at boot. Grepping through /etc
    didn't reveal any startup scripts with a similar message. I seem to recall
    that being mentioned during sid's install, but I can't quite remember the
    context...

    I'm still googlng and grepping, but any further help is appreciated.

    TIA

    Jeff Elkins


    --
    To UNSUBSCRIBE, email to [email]debian-user-requestlists.debian.org[/email]
    with a subject of "unsubscribe". Trouble? Contact [email]listmasterlists.debian.org[/email]
    Jeff Elkins Guest

Similar Threads

  1. Trying to setup a wireless keyboard + mouse
    By J.F.Gratton in forum Debian
    Replies: 0
    Last Post: July 25th, 03:00 AM
  2. how to manually setup wireless network
    By vince in forum Windows Networking
    Replies: 0
    Last Post: July 16th, 02:48 AM
  3. wireless network setup question
    By Grant in forum Windows Setup, Administration & Security
    Replies: 0
    Last Post: July 10th, 01:13 PM
  4. Problems with Wireless connection setup
    By Rob Manger in forum Windows Networking
    Replies: 0
    Last Post: July 9th, 10:03 AM
  5. Wireless Connection Setup
    By Max.. in forum Windows Networking
    Replies: 0
    Last Post: July 9th, 06:57 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139