Professional Web Applications Themes

Won't boot from SCSI drive - Linux Setup, Configuration & Administration

I just picked up a AHA-2940u2w scsi board and a 10k scsi drive. Loaded Fedora. But the only way to boot is from the floppy to /dev/sda1. This being the first time down this path I'm not sure what path to take. Using grub. Tks...

  1. #1

    Default Won't boot from SCSI drive

    I just picked up a AHA-2940u2w scsi board and a 10k
    scsi drive. Loaded Fedora. But the only way to boot
    is from the floppy to /dev/sda1. This being the first
    time down this path I'm not sure what path to take.
    Using grub.

    Tks

    chuck Guest

  2. #2

    Default Re: Won't boot from SCSI drive

    chuck <com> wrote: 

    If your BIOS is able to boot from SCSI you shouldn't have a problem,
    be sure to install grub in the correct way (that I have no clue
    what it is since I've never used grub), maybe you have to make the
    root partition "bootable" from fdisk.

    Davide
    Davide Guest

  3. #3

    Default Re: Won't boot from SCSI drive


    "chuck" <com> wrote in message
    news:qIQEb.192$uswest.net...


    One fault ,totally unrelated to scsi, is to install grub / lilo onto a
    partition,

    without doing two things.
    1. activate the partition (using fdisk, active the same partition, and
    deactive any other that is also active)

    2. have a standard dos/windoze MBR (that simply boots the boot sector off
    the active partition set in Two solutions a) install the standard MBR ( eg
    in dos, fdisk.exe /mbr, will install it )
    b) install grub(or lilo) onto /dev/sda ie "boot=/dev/sda", instead of the
    partition.


     

    check that the scsi board has bios.

    when booting , just after the "power on self test" of the regular bios, it
    will say "adaptec scsi bios version blah" press control-a , and then you
    have a menu .. where you 'enable bios' 'enable booting' etc


     

    well your distribution got this right, hopefully. 


    Leon. Guest

  4. #4

    Default Re: Won't boot from SCSI drive

    chuck wrote:
     

    I think you need to give more information.
    When you try to boot from your SCSI disk
    do you get a "grub>" prompt
    or does the BIOS complain?

    In the first case post your /etc/grub.conf .
    [First try saying "grub-install --recheck /dev/sda".]

    --
    Timothy Murphy
    e-mail (<80k only): tim /at/ birdsnest.maths.tcd.ie
    tel: +353-86-2336090, +353-1-2842366
    s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland
    Timothy Guest

  5. #5

    Default Re: Won't boot from SCSI drive

    On 2003-12-20, chuck <com> wrote:
     

    Have you enabled the AHA-2940's on-board BIOS?

    --

    -John (rr.com)
    John Guest

  6. #6

    Default Re: Won't boot from SCSI drive

    On Fri, 19 Dec 2003 22:00:57 -0700, chuck wrote:
     

    What I had to do when trying to boot from scsi was to turn off all ide
    disks in the pc via the bios, only then would the machine boot from scsi.
    Don't worry about linux, it will find the ide drives without the bios,

    Dave
    --
    And you were born knowing all about ms windows....??

    Dave Guest

  7. #7

    Default Re: Won't boot from SCSI drive

    On Fri, 19 Dec 2003 22:00:57 -0700, chuck <com>
    wrote:
     

    Go into the cmos setup for the scsi board and set the correct 'boot
    from' device.

    Mike-

    Mornings: Evolution in action. Only the grumpy will survive.
    -----------------------------------------------------

    Please note - Due to the intense volume of spam, we have
    installed site-wide spam filters at catherders.com. If
    email from you bounces, try non-HTML, non-encoded,
    non-attachments.


    ----== Posted via Newsfeed.Com - Unlimited-Uncensored-Secure Usenet News==----
    http://www.newsfeed.com The #1 Newsgroup Service in the World! >100,000 Newsgroups
    ---= 19 East/West-Coast Specialized Servers - Total Privacy via Encryption =---
    Michael Guest

  8. #8

    Default Re: Won't boot from SCSI drive

     
    ( eg 
    the 
    Other faults might be in the bios.

    1.
    a. check the motherboard that it can select to boot "Scsi first", and leave
    the IDE drives in the bios
    OR
    b. you have to not have the IDE drive in the bios (but that THEN messes up
    lilo because
    linux doesnt remember the bios code for the drives, and lilo then
    uses the wrong bios code..
    the assumption is that the first ide disk is bios code 0x80, but in
    fact you need lilo to treat sda to
    be bios code 80 )

    OR

    c. you put lilo/grub on the IDE drive, and leave IDE drives configured in
    bios (which avoids the problems with bios)


    2. check that the scsi board has bios.

    when booting , just after the "power on self test" of the regular bios, it
    will say "adaptec scsi bios version blah" press control-a , and then you
    have a menu .. where you 'enable bios' 'enable booting' etc




    Leon. Guest

  9. #9

    Default Re: Won't boot from SCSI drive

    > I just picked up a AHA-2940u2w scsi board and a 10k 

    - maybe you have to make the > root partition "bootable" from fdisk.
    from fdisk:
    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 13 104391 83 Linux

    so it says bootable. This was done by the Fedora CD - what I did was
    boot from the CD (ya-ya keyboard, mouse, new install...) let the
    installer partition automaticly - got this:

    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 13 104391 83 Linux
    /dev/sda2 14 241 1831410 82 Linux swap
    /dev/sda3 242 1101 6907950 83 Linux

    it wanted to know what I wanted installed... I said "everthing".
    I cranked thru all 3 CD's - said something about ".. bootloader .."
    then ask if I wanted a boot floppy. I said yes and was told the
    kernel was too big to fit on a floppy, kicked out CD-3 and told me
    to click on reboot. Nada.

    On the scsi drive the file grub.conf looks fine. Running --recheck
    returns a list of drives ... (hd0) /dev/hda etc.

    On-board bios - now thats a good question. When the scsi board goes
    by during boot I get the standard AHA-2940U2/U2W yada yada ... do a
    ctrl A for utils... then it lists the drive and keeps on going.
    Nothing about booting, bios, etc. If I do the ctrl-A I see words in
    the listing about Boot Dev Opt.. scsi id = 0, lun = 0 ( which are
    changable - and I've tried that) and in the utils I see "items below
    won't work if BIOS is disabled".

    The MB bios (AMI 2.51) - remove all ref to any ide drive - set the
    boot sequence to include the scsi drive ... again nada

    Thanks

    Chuck Guest

Similar Threads

  1. Boot Partition Lost in SCSI Drive
    By adnan in forum Linux / Unix Administration
    Replies: 6
    Last Post: September 3rd, 02:37 PM
  2. Unplug a scsi drive and boot dies
    By Krusty in forum Linux Setup, Configuration & Administration
    Replies: 18
    Last Post: January 7th, 01:02 AM
  3. Lilo: strange warnings when scsi boot + ide-scsi emulation
    By Mannr@uwaterloo.ca in forum Linux Setup, Configuration & Administration
    Replies: 1
    Last Post: August 9th, 01:50 AM
  4. Wrong drive letter assigned to boot drive at install
    By Keith in forum Windows XP/2000/ME
    Replies: 3
    Last Post: August 3rd, 01:12 AM
  5. Replies: 1
    Last Post: June 30th, 05:26 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139