Professional Web Applications Themes

YouTube problems - reverse of others - Macromedia Dynamic HTML

First, you cannot just use the Flash video settings to embed YouTube coding in pages -- though YouTube uses Flash, it has its own system. However, the Dreamweaver javascripts that are supposed to make YouTube visible in IE6 end up making the video disappear in Firefox. (The reverse is true for another guy -- it would appear in Firefox but not IE6.) Whazzup? I teach digital video at MSU that this glitch has been driving me crazy all semester. Isn't there a script that allows embedding YouTube in Dreamweaver pages reliably across all browsers? The solutions I find on Google ...

  1. #1

    Default YouTube problems - reverse of others

    First, you cannot just use the Flash video settings to embed YouTube coding in
    pages -- though YouTube uses Flash, it has its own system. However, the
    Dreamweaver javascripts that are supposed to make YouTube visible in IE6 end up
    making the video disappear in Firefox. (The reverse is true for another guy --
    it would appear in Firefox but not IE6.) Whazzup? I teach digital video at
    MSU that this glitch has been driving me crazy all semester. Isn't there a
    script that allows embedding YouTube in Dreamweaver pages reliably across all
    browsers? The solutions I find on Google don't seem to work either. Help!

    Thanks -
    bucqui

    bucqui Guest

  2. #2

    Default Re: YouTube problems - reverse of others

    http://www.adobe.com/devnet/activecontent/articles/devletter.html

    Something like this should work:

    <script src="Scripts/AC_ActiveX.js" type="text/javascript"></script>
    <script src="Scripts/AC_RunActiveContent.js" type="text/javascript"></script>

    <script type="text/javascript">
    AC_FL_RunContent(
    'width','425','height','355','title','video','src' ,'http://www.youtube.com/v/WNyebAoCUrY&hl=en&rel=0','movie','http://www.youtube.com/v/WNyebAoCUrY&hl=en&rel=0','wmode','transparent'
    ); //end AC code
    </script>
    <noscript>
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="425" height="355" title="video">
    <param name="movie" value="http://www.youtube.com/v/WNyebAoCUrY&amp;hl=en&amp;rel=0" />
    <param name="wmode" value="transparent" />
    <embed src="http://www.youtube.com/v/WNyebAoCUrY&amp;hl=en&amp;rel=0" width="425" height="355"
    movie="http://www.youtube.com/v/WNyebAoCUrY&amp;hl=en&amp;rel=0" wmode="transparent"></embed>
    </object>
    </noscript>


    --
    Ken Ford
    Adobe Community Expert - Dreamweaver
    Fordwebs, LLC
    http://www.fordwebs.com


    "bucqui" <com> wrote in message news:fvi092$64l$macromedia.com... 

    Ken Guest

  3. #3

    Default Re: YouTube problems - reverse of others

    This is the code I use...

    The playYouTube.js file consist of this javascript:


    // JavaScript Doent
    function embedYouTube(videoName,videoWidth,videoHeight) {
    doent.write('<object type="application\/x-shockwave-flash"
    data="http:\/\/www.youtube.com\/v\/' + videoName + '" width="' + videoWidth +
    '" height="' + videoHeight + '"><param name="movie"
    value="http:\/\/www.youtube.com\/v\/' + videoName + '" \/><param name="wmode"
    value="transparent" \/><\/object>');
    }

    It takes the name of the YouTube video as well as its height and width.


    In head of the html:


    <script src="../Scripts/playYouTube.js" type="text/javascript"></script>


    In body of the html:

    <script type="text/javascript">
    embedYouTube("bxLG-rcE-vg&hl=en","425","355"); // file name, width, height
    </script>
    <noscript>
    <object type="application/x-shockwave-flash"
    data="http://www.youtube.com/v/bxLG-rcE-vg&hl=en" width="425" height="355">
    <param name="movie" value="http://www.youtube.com/v/bxLG-rcE-vg&hl=en" />
    <param name="wmode" value="transparent" />
    </object>
    </noscript>

    CaryD Guest

Similar Threads

  1. Flash problems with Youtube HELP!
    By Dynawolf in forum Macromedia Flash Player
    Replies: 11
    Last Post: December 2nd, 12:42 AM
  2. YouTube Problems
    By Nightgaunt88 in forum Macromedia Flash Player
    Replies: 3
    Last Post: April 26th, 06:20 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139